Cloudflare have now removed their status page incident, indicating that the issues experienced today are fully resolved.
With that in mind, we are resolving our status page incident as no further issues are being detected.
If you have any further problems, please don't hesitate to contact our Client Support Team on 01392826980 (Option 1) between 8am-8pm
Posted Nov 18, 2025 - 19:47 UTC
Update
Cloudflare have reported that a fix was implemented at 14:42 and the incident is now resolved. However, DigiTickets will continue to monitor for errors until all services are back to normal.
Posted Nov 18, 2025 - 14:54 UTC
Update
We are continuing to monitor for any further issues.
Posted Nov 18, 2025 - 12:18 UTC
Monitoring
We have identified an issue that is currently affecting the DigiTickets and Website Vision platforms/websites. We're aware that this may be affecting some users and customers. The issue appears to be stemming from performance issues by Cloudflare which will be affecting websites across the internet intermittently.
During this time, the functionality of the platform may be impacted and you may experience slow responses, error messages and more.
We are working with our engineering teams to monitor this situation and actioning anything we can on our side to elevate this issue as quickly as possible.
Systems Affected: Back Office, Online Ticketing, DigiTickets Website, ProPoint Time in which the incident started: 11:40 BST (UTC+1) Estimated Time of Restoration: Unknown as due to an external platform
We apologise for any inconvenience this outage is causing and we are working extremely hard to get this resolved as quickly as possible.
We will provide our next update as soon as possible. However, you can also view Cloudflare's status page at https://www.cloudflarestatus.com/ to view their progress with this issue.
Posted Nov 18, 2025 - 11:51 UTC
This incident affected: Back Office, Online Ticketing, ProPoint, and DigiTickets Website.