Issues with Payyo
Incident Report for DigiTickets
Resolved
The Payyo Support Team have now confirmed that this issue has been resolved.
Posted Jun 09, 2022 - 11:47 UTC
Investigating
We've noticed some customers are currently having issues taking payments with Payyo. We're communicating with Payyo and their Support Team, and will continue to post updates as soon as we have them. If you are a Payyo customer you can also email support@payyo.ch for more assistance.
Posted Jun 09, 2022 - 09:37 UTC
This incident affected: Online Ticketing.